Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Bluetooth Verbindung
10.03.2018, 16:44
Beitrag: #1
Bluetooth Verbindung
Hallo Forum,
ich bin Carsten aus Berlin, 47 Jahre jung mit einer 88er KLR650.

Ich habe schon in ein paar Threads gewühlt, komme aber nicht weiter.

Vor ein paar Monaten hatte ich mir einen IQ11 gelötet. Anfänglich ging die Bluetoothverbindung noch, dann nur sporadisch, nun gar nicht mehr. Deshalb habe ich mir zusätzlich zum BT-Modul (HC-06 von Dete) ein USB-Modul besorgt. Per USB und RehoilerMultiApp klappt alles wunderbar.

Nur leider kein Bluetooth...

Spannung am IQ11: 10,4 V (etwas dünne)
Spannung am HC-06: 5,0 V
Das BT-Modul blinkt rot.
Die neue App Rehoiler IQ 1.0.0.139 ist installiert.
HC-06 wird von der App gefunden.
Wenn ich HC-06 anwähle, kommen per Hint folgende Meldungen: "Verbinde ..." und dann "Verbunden mit HC-06". Aber eine Verbindung besteht nicht.

Hat jemand einen Tipp für die Fehlersuche?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.03.2018, 19:07 (Dieser Beitrag wurde zuletzt bearbeitet: 10.03.2018 21:15 von turboschleicher.)
Beitrag: #2
RE: Bluetooth Verbindung
Hallo Carsten,
wo gibt es denn beim IQ11 10,4VHuh
Du hast eine Eingangsspannung, also Boardspannung vom Motorrad. Wenn die bei 10,4V liegt ist deine Batterie schon sehr entladen bzw. defekt.
Wäre jetzt aber für die reine Elektronik egal, da die Platine mit 5V arbeitet bzw. die Neuen IQ11 mit 3,3V und die werden vom Festspannungsregler geliefert.
Dein BT wird von der App gefunden und verbindet auch (BT-LED leuchtet dann rot).
Einstellungen mit der App ändern geht aber nichtHuh
Mögliche Ursachen:
Am BT-Modul, RX, TX defekt. Neuer BT erforderlich.
Am Controller, RX, TX defekt. Können zwar mit dem USB-Modul noch funktionieren aber mit dem BT-Modul nicht mehr so richtig. Neuer Controller erforderlich.
Firmware auf dem Controller hat einen Schuss abbekommen. Dieses Problem hatte ich schon des öfteren. Da hat es ausgereicht, die Firmware einfach nochmals draufzuspielen.
Bevor du dir aber die Mühe machst, probier erst einmal einen Reset.Big Grin

Grüsse
turboschleicher

Support Schweiz
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.03.2018, 10:45 (Dieser Beitrag wurde zuletzt bearbeitet: 11.03.2018 11:41 von planet.)
Beitrag: #3
RE: Bluetooth Verbindung
Danke für deine schnelle Antwort.

Ja 10,4 V Eingangsspannung vom Bordnetz meinte ich. War mir nur nicht sicher, ob das ausreicht. Batterie ist ok. Die Spannung geht irgendwo auf dem Weg zum Rehoiler verloren. Werde ich später mal prüfen.

Die BT-LED blinkt weiterhin, wenn ich versuche, zu verbinden. Also keine Verbindung.

Reset ändert leider nichts.

Mir ist aufgefallen, dass Tx / Rx bei BT und USB unterschiedlich belegt sind. Ist aber auch in der IQ11 Anleitung so zu sehen.

Werde mich also mal an der Firmware versuchen. Danke nochmal! Smile
Habe nun die Firmware neu aufgespielt. Leider keine Änderung.

Kann man die Rx/Tx Funktion auf dem Controller denn irgendwie prüfen?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.03.2018, 21:26 (Dieser Beitrag wurde zuletzt bearbeitet: 11.03.2018 21:27 von turboschleicher.)
Beitrag: #4
RE: Bluetooth Verbindung
Hallo Carsten,
zuerst würde ich mal den Fehler mit den 10,4V beheben.Exclamation
dann schreibst du das es via RehoilerMultiApp und USB geht.
Hat dein PC auch Bluetooth???
Wenn ja versuche einmal eine Verbindung via Bluetooth am PC mit der RehoilerMultiApp.

Grüsse
turboschleicher

Support Schweiz
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.03.2018, 15:02
Beitrag: #5
RE: Bluetooth Verbindung
Hallo turboschleicher

Die Bordspannung ist jetzt ok. Danke für den Arschtritt. Smile Es war wohl eine Steckverbindung am Zündschloss oder das Zündschloss selbst.

Die Verbindung am PC bekomme ich nicht hin. Bin aber nicht sicher, ob ich alles kapiere. HC-06 lässt sich mit dem PC koppeln. Im Gerätemanager sehe ich zwei COM-Ports (4 + 5), wenn ich meinen BT-Dongle einstecke. RehoilerMultiApp verbindet aber weder mit COM4 oder COM5. Mache ich hier was falsch?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.03.2018, 23:08
Beitrag: #6
RE: Bluetooth Verbindung
Hi,
möchte nicht mit Geschichten vom "vor dem Krieg kommen" Wink , aber ich hatte mal ein BT-Modul bei dem schlicht und einfach Tx und RX falsch beschriftet waren. "I schwöa".

Roland
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.03.2018, 23:29
Beitrag: #7
RE: Bluetooth Verbindung
Hallo Roland,
ja da hast du schon recht.Big GrinBig GrinBig Grin
Guckst du hier, da habe ich das auch schon mal geschrieben. Klick

Grüsse
turboschleicher

Support Schweiz
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
19.03.2018, 01:07
Beitrag: #8
RE: Bluetooth Verbindung
Also doch eine Geschichte aus der GeschichteAngel
Greets

R
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.03.2018, 18:15
Beitrag: #9
RE: Bluetooth Verbindung
Grüezi nochmal,
habe mir nun ein zwetes BT-Modul besorgt und ausprobiert. Leider genau wie vorher. Keine Verbindung mit der App. Die "Hinweisblase" sagt: "Verbunden mit HC-06", aber es besteht keine Verbindung zur App, also es werden keine Werte angezeigt.

Brauche ich eventuell einen neuen Prozessor?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.03.2018, 20:03
Beitrag: #10
RE: Bluetooth Verbindung
Schick mir doch einfach mal die Module und den Prozessor, dann kann ich das relativ schnell beantworten.
Oder hast du auch ein USB Modul, dann könntest du testen ob dein HC-06 Module überhaupt auf AT Befehl antworten.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:


Kontakt | Startseite | Nach oben | Zum Inhalt | Archiv-Modus | RSS-Synchronisation