#1 RE: CBR 900 Tachosignal von brun0x 09.05.2015 20:54

Hallo liebe Gemeinde,

dem Dete hab ich schon eine Mail geschrieben bzgl. mein Problem zu meinem Tachosignal am Moped.
Bei mir ists anscheinend so, dass ich vom Drehzahlgeber (welcher die Umdrehungen der Ritzelschraube aufnimmt) ein 1V Signal als Leerlauf und ein 12V Signal als Takt bekomme (hatte nur Multimeter zum Messen).

Nach Turboschleicher zählt der Rehoiler die negative Flanke (0V Spannung?), dann sollte ich doch mit einem 7805 Spannungsregler arbeiten können. Der gibt mir anstelle 12V => 5V raus und anstelle 1V => 0V (bzw. schaltet er Masse durch).

Würde ich damit mein Problem beheben können?

Gruß, Fritz

#2 RE: CBR 900 Tachosignal von turboschleicher 09.05.2015 21:32

avatar

Hallo Fritz,
mit einem Festspannungsregler wird das wohl leider nicht gehen.
Der Festspannungsregler benötigt um richtig arbeiten zu können eine Gleichspannung. Bei einem Impulssignal wird der wohl verrückt spielen.
Du könntest einen Spannungsteiler mit 2 Wiederständen machen.
Oder eine Z-Diode (Atmegapegel), also high Signal) so ab 3,0-5,1V mit Vorwiderstand.
Oder sogar galvanisch getrennt, mit einem Optokoppler.

Grüsse
turboschleicher

#3 RE: CBR 900 Tachosignal von brun0x 09.05.2015 22:46

Hallo Turboschleicher,

das mit der Z-Diode und dem Widerstand sollte die einfachste Lösung mit guten Erfolgschancen sein

Danke Dir!!!

Gruß, Fritz

#4 RE: CBR 900 Tachosignal von Dete 10.05.2015 09:55

Moin, was sagt den die Impulsanzeige?

Sehr wahrscheinlich wird ein ein Vorwiderstand schon reichen, hat bei der BMW F800 auch zum Erfolg geführt.

#5 RE: CBR 900 Tachosignal von brun0x 11.05.2015 09:08

Guten Morgen allerseits,

so wie mir das mein Elektronikerkollege eben mitgeteilt hat, sollte der Rehoiler ein TTL-Signal verarbeiten (?). Dann könnte ich doch ganz einfach einen Spannungsteiler reinsetzen, der mir die niedrigere Spannungsflanke unter 0,8V setzt. Oder welches Signal braucht der Rehoiler direkt?

Gruß, Fritz

#6 RE: CBR 900 Tachosignal von turboschleicher 11.05.2015 17:43

avatar

Hallo Fritz,
ja wie ich dir schon oben geschrieben habe, Spannungsteiler, also mit 2 Widerständen.:D:D:D
Oder eben wie Dete aus Erfahrung weiss, reicht sehr oft schon 1 Widerstand.

Grüsse
turboschleicher

#7 RE: CBR 900 Tachosignal von Erich1050 11.05.2015 17:44

Hallo Fritz,

ja der Rehoiler verarbeitet TTL-Pegel. Das bedeutet:
High-Pegel entspricht 5V und Low-Pegel entspricht 0V.

Da der Atmel da aber nicht ganz so kritisch ist mit den Pegeln geht auch z.B. 0,3V noch als Low Signal durch und z.B. 3,5V als High Signal.

Deine Signalanpassung kannst Du nnatürlich über einen Spannungsteiler realisieren, es geht allerdings auch mit nur einem Vorwiderstand, da der Eingangswiderstand des Eingangs-Port des Atmel ja auch einen Widerstand hat und somit zusammen mit dem Vorwiderstand einen Spannungsteiler bildet.

Viele Grüße
Erich

#8 RE: CBR 900 Tachosignal von brun0x 11.05.2015 21:42

ok, mit reinem Vorwiderstand im Verbund mit dem Atmega erscheints mir nun auch ersichtlich.

Ich weiß nicht was ich am Wochenende gemessen hatte, aber es scheint zu Funktionieren. Habe am Signalkabel vom Speedsensor ein sauberes TTL-Signal vorhanden mit satten 5V und ein paar mV.

Trotzdem Danke für eure Hilfe, klasse Sache hier das alles.
Kann euch und den Rehoiler nur weiterempfehlen (was ich schon getan habe).

Gruß, Fritz

Xobor Einfach ein eigenes Forum erstellen | ©Xobor.de
Datenschutz