#1 RE: Update COM Port nicht vorhanden von flydown 14.01.2017 16:15

Hallo liebe Rehoilergemeinde,

ich habe mir einen Rehoiler IQ10 gelötet mit der Platine vom Dete und auch einem vom Meister programmierten Prozessor.
Dazu das HC06 Blauzahnmodul.
Mit dem Handy (Android 6.x) klappt die Verbindung auch erstmal prima, Dauerpumpen funktioniert, Impulsanzeige funktioniert, auch die Version und eingestellte Werte werden angezeigt, allerdings IQ8.07
Verbinde ich allerdings mit meinem Netbook, COM 35, und der PC Version, werden Werte angezeigt, aber andere als auf dem Handy, und das Fenster "DataLog" bleibt leer. Ich kann auch scheinbar keine Werte ändern und die letzte Zeile ist die mit dem "Tacho Impulslernmodus On". Kann aber am Bildschirm liegen.
Versuche ich COM 36 hängt das Programm sich auf.

Nun dachte ich, naja, mach mal Update auf IQ10.03, vielleicht geht's dann.
Wie's geht, habe ich hier gefunden.
Also den an143_bootloader gestartet, allerdings finde ich dort meinen COM 35 nicht. Der zeigt nur bis COM 15.

Das HC06 habe ich schonmal vom Rechner geschmissen und neu installiert, danach auch die COM Ports kontrolliert.

Was kann ich also tun?


Ganz viele Grüße und Dankeschön
Uwe

#2 RE: Update COM Port nicht vorhanden von turboschleicher 14.01.2017 16:52

avatar

Hallo Uwe,
ja Dete hat da mal ein Paar Controller verwechselt.
Also Update solltest du auf jedenfall machen.
Bei der Windowsversion, welches Windows hast du installiert???
Also zuerst dein Bluetooth suchen und dann koppeln.
Wenn das Koppeln geklappt hat, im Gerätemanager nachschauen welche/r Comport's zugeteilt worden sind.
Sind meisstens 2. Diese merken.
Dann APP starten und mal den 1sten Auswählen, dann auf verbinden und dann auf auslesen.
Wenn der nicht geht den anderen ausprobieren.:D

Grüsse
turboschleicher

#3 RE: Update COM Port nicht vorhanden von flydown 14.01.2017 17:31

Hallo


und vielen Dank schonmal.

Das Windows ist das 7 Starter.
Im Gerätemanager habe ich extra nachgesehen, auch bei der Installation darauf geachtet.
Deswegen auch die Zündung, darüber wird der Öler geschaltet, ausgemacht, bis 10 gezählt, wieder eingeschaltet, HC06 wieder de- und neuinstalliert...

Wenn das HC06 nicht verbunden ist, taucht es ja im Gerätemanager nicht auf.
Dort ist es aber, der COM wir nur leider nicht im Bootloaderprogramm angezeigt.

Nehme ich den anderen COM Port, friert das Programm wie gesagt mit dem Startbild ein. Manchmal gibts vom Windows eine Fehlermeldung, manchmal muß ich es mit dem Taskmanager beenden.


Viele Grüße
Uwe



Hallo nochmal,

was wäre denn davon zu halten, die belegten COM Ports zu löschen und das HC 06 neu zu koppeln, in der Hoffnung, daß es unter den ersten 15 landet?

Oder mache ich damit Schaden im Rechner? Die Liste der COMs ist seeehr lang.

Ich würde das mit device cleanup machen, weiß aber nicht genau, was dann ist.
Aber ein Gerät würde doch einfach neu zugewiesen werden?


Viele Grüße
Uwe

#4 RE: Update COM Port nicht vorhanden von flydown 15.01.2017 13:36

Hallo wieder.

Also zunächst mal, Dete hat wohl alles richtig gemacht.
Ich war ja dabei, als er meine beiden Prozessoren nacheinanderweg programmiert und geprüft hat. Da hat's ja auch funktioniert.

Ich habe eben, mangels Zeit heute, in einer Hauruckaktion mal den anderen Prozessor eingesetzt und siehe da- funktioniert prima.
Version 10.05, 7 getätigte Pumpvorgänge, Meldungen im Datalogfenster, Programm schließt richtig usw... Auch im Handy alles prima.

Aber warum?

Den Updateversuch bei dem ersten Prozessor konnte ich heute machen.
Jedenfalls lief nach loslassen des Platinentasters unten links im Bootloaderprogramm die grüne Statusanzeige, eine Endmeldung gab es auch.
Irgendwas mit 0?

Ich wüßte nichts, was ich mit dem ersten Prozessor falsch gemacht haben könnte, das HC06 hat jedenfalls definitiv immer richtig im richtigen Steckplatz gesessen.

Naja, rüste ich mal bei Gelegenheit die beiden zusätzlichen Widerstände nach und mache einen IQ11 daraus.


Ganz viele Grüße
Uwe

P.S. Gibt es einen Trick, mit dem ich mir auf meinem kleinen Klapptop auch die Felder unterhalb der Zeile mit dem Tachoimpulslernmodus anzeigen lassen kann?

#5 RE: Update COM Port nicht vorhanden von Dete 15.01.2017 16:30

Zitat von flydown

P.S. Gibt es einen Trick, mit dem ich mir auf meinem kleinen Klapptop auch die Felder unterhalb der Zeile mit dem Tachoimpulslernmodus anzeigen lassen kann?



Hast du die Anzeige auf mehr 100% eingestellt?

#6 RE: Update COM Port nicht vorhanden von flydown 16.01.2017 17:03

Wunderschönen guten Tag,

das weiß ich nicht.
Ich kann jedenfalls nicht mit Strg+ oder Strg- die Anzeige vergrößern oder verkleinern. Scrollen geht auch nicht.
Weder bei Voll- noch Kleinbild.

Viele Grüße
Uwe

Xobor Einfach ein eigenes Forum erstellen | ©Xobor.de
Datenschutz