Seite 1 von 2
#1 Dauersignal am Pumpenausgang von Schoenwetterfahrer 12.03.2020 17:59

avatar

Hallo Gemeinde,
vielleicht kann mir jemand weiterhelfen:
Benutzte den IQ11 bislang mit GPS. Da ich den Eindruck hatte, das dieses nicht ordentlich funktioniert hatte ich beschlossen
diesen auf Reed zurückzubauen. Also IC1 gegen ein 7805 ersetzt. Nach dem Einbau ins Mopped
machte der Baustein schon nicht das, was laut Anleitung sein sollte, also Rotes und gelbes zuerst, dann dauerrot. Dann hab ich alles
wieder ausgebaut und auf meinem Schreibtisch eine Schalte für das Modul aufgebaut. Auf Anhieb hat alles so funktioniert wie es sollte,
beim Versuch, alle weiteren Funktionen zu testen hab ich jetzt den Effekt, das weder das rote noch das gelbe LED
auf der Platine leuchten und der Ausgang Pumpe (simuliert durch LED) ständig leuchtet.
Ich vermute, dass ich den Mega 8 geschrottet habe. Vielleicht kann mir das einer aufgrund der Symptome bestätigen.
Frage wäre auch, wo bekomme ich einen neuen her???

Gruß
Jürgen

#2 RE: Dauersignal am Pumpenausgang von turboschleicher 12.03.2020 21:08

avatar

Hallo Jürgen,
wenn du auf Reedkontakt umstellen willst, musst du deswegen nicht auf 5V zurück bauen.
Einfach RehGPS weg und Reedkontakt anschliessen, fertig.
Aber Reedkontakt, richtig anschliessen, also der eine Draht an den Eingang (Tachosignal) und den anderen Draht an Minus.
Für die Betriebssicherheit, natürlich besser. Die meissten HC-06 brauchen min 5V Eingangsspannung, damit sie sauber funktionieren.
Und dein Mega 8 ist übrigens ein Atmega 168.
Wenn dein IQ11 dann auf 5V umgebaut ist, solltest du aber auch die v.11.0 aufspielen, damit deine Spannungsanzeige wieder stimmt.
Auch, nur eine LED zum Test am Pumpenausgang anzuschliessen, führt gerne dazu, das es ein Dauerleuchten wird, da die Last zu gering ist.
Wie sieht es denn mit dem BT-Modul aus, geht das denn noch?
Dein Controller muss nicht zwingend defekt sein. Mache erst mal einen Reset.

Grüsse
turboschleicher

#3 RE: Dauersignal am Pumpenausgang von Mega 12.03.2020 21:39

Zitat von Schoenwetterfahrer im Beitrag #1
Da ich den Eindruck hatte, das dieses nicht ordentlich funktioniert hatte ich beschlossen
diesen auf Reed zurückzubauen.

Ist es ein subjektiver Eindruck oder durch was zeigt sich objektiv/ durch nachvollziehbare Effekte?
Bevor man einen technischen Rückschritt (Rückbau auf Reed) macht, sollte man doch erst prüfen ob wirklich eine Funktionsstörung vorliegt. :denk

Gruß Jürgen

#4 RE: Dauersignal am Pumpenausgang von turboschleicher 12.03.2020 22:03

avatar

Einen Rückschritt machst du ja beim IQ11 nicht.
An dem änderst du ja eigentlich nicht´s.
Der RehGPS ist ja für Leute gedacht die keinen Reedkontakt bzw. das Tachosignal nicht anzapfen möchten.
Ob jetzt Reedkontakt-Signal, Tachosignal oder eben ein Tachosignal erzeugt vom RehGPS verwendet wird ist dem IQ11 egal.
Gehen wir jetzt erst mal auf Fehlersuche:

Zitat
Wie sieht es denn mit dem BT-Modul aus, geht das denn noch?


Baue den IQ11 ins Moped.
BT-Modul nicht aufgesteckt.
Tachosignal bzw. Reedkontakt ausgesteckt, Pumpe auch ausgesteckt, Cockpittaster auch ausgesteckt.
Jetzt einschalten und beobachten ob die Platinen LED´s den Einschalttest durchführen.
Wenn ja dann BT-Modul wieder draufstecken und wieder den IQ11 einschalten und Platinen LED´s beobachten.
Dann Tachosignal bzw. Reedkontakt wieder anschliessen und Platinen LED´s beobachten.
Dann Cockpittaster wieder anschliessen und Platinen LED´s beobachten.
Zu guter letzt die Pumpe wieder anschliessen und Platinen LED´s beobachten.

Und berichte

Grüsse
turboschleicher

#5 RE: Dauersignal am Pumpenausgang von Schoenwetterfahrer 17.03.2020 12:59

avatar

Hallo turboschleicher,

danke für deine kompetente Antwort zu dem Thema.
Ich habe deine Anleitung zur Fehlereingrenzung gemacht,
werde aber schon bei dem ersten Schritt gestoppt.
D.h. Keine Komponenten angeschlossen, nur 12 Volt gem. Belegung:
Ergebnis: Kein Leuchten der Platinen LED´s
12 Volt liegen an, der 7805 hat am Ausgang seine 5 Volt.

Nun brauch ich neuen Rat!!

Gruß
Jürgen

#6 RE: Dauersignal am Pumpenausgang von turboschleicher 17.03.2020 20:57

avatar

Hallo Jürgen,
hast du am ATMega 168 zwischen PIN 7 (VCC) und PIN 8 (GND) deine 5V?


Und wenn der BT-Adapter drauf ist, blinkt die rote LED auf dem BT-Adapter?

Grüsse
turboschleicher|addpics|t7m-4-d43b.jpg-invaddpicsinvv|/addpics|

#7 RE: Dauersignal am Pumpenausgang von Schoenwetterfahrer 18.03.2020 10:07

avatar

Hallo,
zwischen PIN 7 und 8 messe ich die 5 Volt
wenn ich den BT Adapter aufstecke blinkt die rote LED auf dem Adapter

#8 RE: Dauersignal am Pumpenausgang von Schoenwetterfahrer 18.03.2020 10:37

avatar

Weiter in der Fehlersuche:

Die Ausgänge 11 und 13 scheinen nicht zu schalten,
die LED´s auf der Platine sind in Ordnung

#9 RE: Dauersignal am Pumpenausgang von Schoenwetterfahrer 18.03.2020 10:47

avatar

Weiter in der Fehlersuche:

Das BT-Modul blinkt dauerhaft, wenn ich mit der App verbinde,
blinkt sie im Doppeltakt mit Pause, ich kann aber weder Daten lesen noch schreiben

#10 RE: Dauersignal am Pumpenausgang von turboschleicher 18.03.2020 14:59

avatar

Hallo Jürgen,
es sieht fast so aus das du dir den Controller zerschossen hast.
Ich würde jetzt aber noch versuchen die Software nochmal aufzuspielen.

Grüsse
turboschleicher

#11 RE: Dauersignal am Pumpenausgang von Schoenwetterfahrer 18.03.2020 15:35

avatar

Das war auch meine Vermutung,
wie kann ich die Software aufspielen?
Ein USB Modul habe ich nicht

#12 RE: Dauersignal am Pumpenausgang von turboschleicher 18.03.2020 18:23

avatar

Hallo Jürgen,
wenn der Controller noch leben sollte und der Bootloader noch funktioniert, dann geht das auch mit dem BT-Modul.
Dazu gehst du auf die Bascomseite und lädst dir das Programm bootloader.exe runter klick mich
IQ11 Software klick mich
Beides dann natürlich entpacken.

Jetzt musst du natürlich erst einmal dein BT-Modul mit deinem Windows PC koppeln.
Und dann geht es los:
1. Controller in den Rehoiler und mit Spannung versorgen.
2. Jetzt bootloader.exe starten, Comport deines BT-Modules eingeben, Bautrate auf 9600. Dann auf select file deine v.11.0 auf deinem PC suchen und auswählen.
3. Den Platinentaster gedrückt halten.
4. Jetzt auf File und Upload starten.
5. Wenn das #123.. kommt, Platinentaster los lassen. Der Upload sollte jetzt starten.
6. Das war es auch schon.

Wenn der Upload nicht starten sollte, nimm ein Stück Draht, schliesse es am Minus an und halte es, wenn du den Upload gestartet hast, kurz an der Reset PIN 1 am Controller.

Viel Erfolg

Grüsse
turboschleicher

#13 RE: Dauersignal am Pumpenausgang von Schoenwetterfahrer 19.03.2020 13:29

avatar

Also,

außer Sending #123 passiert nichts weiter,
auch Masse an Pin 1 hat nichts gebracht...
Ergebnis: Controller kaputt, dann brauch ich einen neuen

Wer kann mir einen schicken??

#14 RE: Dauersignal am Pumpenausgang von turboschleicher 19.03.2020 15:55

avatar

Hallo Jürgen,
du meinst einen fertig programmierten Controller
Habe gerade meine letzten AT168 aufgebraucht.
Neue habe ich zwar schon bestellt...
...Ich bestelle aber meine Controller immer in Asien. Und das geht meistens so 6-12 Wochen. Jetzt wegen Corona wahrscheinlich noch länger.
Wenn es bei dir in der Nähe einen Elektronikladen hat, dann hol dir dort einen.
Zum programmieren kannst ihn dann mir schicken.

Grüsse
turboschleicher

#15 RE: Dauersignal am Pumpenausgang von Schoenwetterfahrer 04.04.2020 11:36

avatar

Hallo Thomas,

danke für deine prompte Hilfe zum Thema Rehoiler.
Unser Telefonat hat mal wieder gezeigt, das die Tücke im Objekt liegen kann.
Seien es die Probleme, die das nicht bleihaltige Lötzinn mit sich bringt,
oder die Tatsachen, das die wenigsten die Möglichkeiten der ganzheitlichen Prüfung
des Rehoilers haben.
Vielleicht kann man zu diesem Thema mit der 5 Volt bzw. 3,3 Volt Versorgung
nochmal einen Thread aufmachen, wenn nicht schon passiert.

Wichtig für alle aber, hier können die Leute auf kompetente Hilfe hoffen,
wenn es auch manchmal etwas länger dauert.

Ich warte jetzt darauf, meinen Rehoiler mit GPS wieder einbauen zu können und
dann auch ausgiebig testen zu können.

Bleib gesund!!

Gruß
Jürgen

Xobor Einfach ein eigenes Forum erstellen | ©Xobor.de
Datenschutz