Seite 1 von 2
#1 RE: Sicherung durchgebrannt von Ensomhet 18.11.2013 21:14

Hallo,

ich habe den Rehoiler heute soweit am Motorrad angebaut, dass ich mal eine Testfahrt machen wollte, um zu schauen, ob der Reedkontakt auch bei Geschwindigkeiten, die höher als "Handgeschwindigkeit" sind, funktioniert. Also habe ich die "Impuls-Anzeige" aktiviert, die Platine so platziert, dass ich sie während der Fahrt sehen konnte und bin losgefahren. Es schien zu Anfang alles zu funktionieren, nach einigen Kilometern jedoch war plötzlich das Blinken weg und die rote LED leuchtete auch nicht mehr. Also wieder nach Hause und erstmal die Sicherung überprüft. Sie war durchgebrannt. Der Rehoiler scheint noch zu funktionieren, aber was mache ich wegen der Sicherung? Ich habe eine träge 2,5 A Feinsicherung verwendet. Woran kann es liegen, dass sie durchgebrannt ist? War bei höherer Drehzahl eventuell ein zu hoher Strom und dadurch ist dann die Sicherung durchgebrannt? Hätte ich unsauber gearbeitet und es wäre ein Kurzschluss entstanden, dann wäre ja wahrscheinlich nicht nur die Sicherung des Rehoilers durchgebrannt sondern auch die vom Rücklicht (dort habe ich den Strom her), oder nicht?
Soll ich einfach eine Sicherung mit höherem Grenzwert nehmen oder brennt dann statt der Sicherung ein Bauteil auf der Platine durch?

#2 RE: Sicherung durchgebrannt von turboschleicher 19.11.2013 21:01

avatar

Hallo Evren,
ich habe mal im meinem Labor nachgemessen. Die Pumpe zieht bei 12V ca. 2200mA und bei 13,8V sind es sogar 2600mA.
Hinzu kommt noch was die Platine braucht.
Minimum (ohne Pumpe) keine 100mA je nachdem wieviele LED gemeinsam an sind bis so um die 200mA.
Das wären bei 12V dann 2400mA
und bei 13,8V 2800mA, also deutlich mehr als deine verwendetet Sicherung verträgt.
Da die Batterie ja geladen wird beträgt ja die Spannung immer über 12V.
Der Transistor der die Pumpe schaltet, ist ein 30A, 50V, 0.040 Ohm, N-Channel Power MOSFET. Der stirbt nicht so schnell.
Ich würde zum Schutz vor Kurzschluss, mit 3A - 4A träge absicherern.

Grüsse
turboschleicher

#3 RE: Sicherung durchgebrannt von Ensomhet 20.11.2013 00:23

Hallo turboschleicher,
danke für deine Mühe. Ich werde es dann mal mit einer 3 A Flachsicherung versuchen, da ich davon noch welche da habe. Das sollte dann ja hoffentlich halten. Und wenn nicht, dann besorge ich mir welche mit 4 A.

Es haben sich nach meinem heutigen weiterarbeiten aber zwei weitere Fragen aufgeworfen.
Teil 1:
Ich habe das Kabel für die Regen- und Cockpit-LED und den Taster gelötet und mal schnell ausgetestet. Dabei stellte ich fest, dass die Kabel genau anders herum in die Klemmen müssen als gedacht. Ich habe zuerst folgendes gehabt:
Klemme 5 -> Regen-LED (+) -> Cockpit-LED (-)
Klemme 6 -> Regen-LED (-) -> Cockpit-LED (+)
So leuchtete zu Anfang jedoch die gelbe LED für ein paar Sekunden. Nachdem ich das einfach umgedreht habe zu:
Klemme 5 -> Regen-LED (-) -> Cockpit-LED (+)
Klemme 6 -> Regen-LED (+) -> Cockpit-LED (-)
schien es erst richtig zu sein.

Teil 2:
Dann aber merkte ich, das viel mehr als nur das nicht stimmt, was die zwei LEDs angeht:
Bei Stromzufuhr leuchtet die grüne LED zuerst ein paar Sekunden, dann ist sie ein paar Sekunden lang wieder aus und leuchtet danach dauerhaft.
Wenn ich den Taster betätige, während die grüne LED für ein paar Sekunden aus ist, dann leuchtet normal die gelbe LED beim ersten betätigen dauerhaft, beim zweiten blinkt sie zwei mal auf und leuchtet dann dauerhaft und beim dritten Mal ist sie wieder aus. Dann beginnt wieder die kurze Pause, in der nichts leuchtet, und dann leuchtet Grün wieder dauerhaft (Also der Zustand, der eingetreten wäre, wenn ich in der Phase, in der nichts leuchtete, den Taster nicht betätigt hätte).

Wenn ich nun den Taster drücke, nachdem Grün mit dem Dauerleuchten angefangen hat, dann geht die grüne LED aus und bleibt auch aus.
Wenn ich ihn nochmal betätige, blinkt die grüne LED zwei mal und geht dann wieder aus.
Beim dritten Betätigen ist die grüne LED dann wieder dauerhaft eingeschaltet.
Und dann fängt es wieder von vorn an (LED geht wieder aus, ....).

Nachdem ich einmal gedrückt halte, um dauerzupumpen, und dann wieder aufhöre, habe ich wieder kurz den Zustand, in dem nichts leuchtet (wenn ich den Taster drücke, die gelbe LED wieder aufleuchtet, beim nächsten Drücken zwei mal blinkt und dauerleuchtet und beim dritten Mal wieder aus ist und kurz darauf die grüne wieder dauerleuchtet, wenn man wartet und nicht den Taster erneut wieder betätigt) und dann kommt der Zustand, in dem die Grüne dauerleuchtet...
Also ziemlich seltsam. Ich hoffe, ich konnte es halbwegs verständlich rüberbringen.

Habe ich etwas falsch verkabelt, was die LEDs angeht?


Edit: Nachdem ich die Düse heute fertiggestellt habe, habe ich mal eine Testfahrt gemacht. Der zweite Teil hat sich damit eigentlich fast komplett erledigt. Ich konnte feststellen, dass das Dauerleuchten der grünen LED signalisiert, dass kein Signal vom Reedkontakt mehr kommt, stimmts? Jedenfalls ging die grüne LED immer dann an, wenn ich zum stehen kam. (gestern hatte ich einen Test im Stand gemacht, deswegen war mir das nicht gestern schon aufgefallen)
Aber was hat es damit auf sich, wenn man den Taster drückt, während die grüne LED dauerhaft leuchtet? Dazu habe ich nichts in der Anleitung finden können. Aber ich habe auch zu dem "signalisieren, dass kein Signal mehr vom Reedkontakt kommt" nichts in der Anleitung finden können.

Und der erste Teil bleibt noch - warum musste ich die LEDs verkehrt herum anschließen?

#4 RE: Sicherung durchgebrannt von turboschleicher 20.11.2013 21:34

avatar

Hallo Evren,
die LED's sind so wie im Schaltplan schon richtig. Also beim einschalten sollte die grüne LED ca. 3 sekunden an bleiben.
Wenn also deine gelbe LED für ca. 3 Sekunden leuchtet, dann hast du einfach nur die Polarität verwechselt. Also einfach wie du es gemacht hast, an der Klemme Drähte tauschen.
Ich empfehle dir aber auch noch einen Werkreset zu machen. Oder du hast schon USB oder Bluetooh Verbindung mit dem Rehoiler. Dann siehst du ja die Werte und kannst sie anpassen.
RESET- Auslieferungszustand:
• Das System abschalten (? Zündung Aus).
• Platinentaster gedrückt halten.
• Das System einschalten (? Zündung Ein) und den Taster noch weitere 5 Sekunden gedrückt
halten.
Anschließend sind alle Werte wieder auf den Auslieferungszustand gesetzt.
Das bedeutet:
• 1 Impuls pro Radumdrehung.
• Tankvolumen 100 ml.
• Leuchtdauer der Cockpit-LED 750 ms.
• Automatischer Notbetrieb ist aktiv.

Jetzt nochmal zur gelben LED. Diese wird durch den Reedkontakt angesteuert. Bist du vielleicht noch im Testmodus?
Schalter DS 2+4 Impulsanzeige auf on.
Dies bedeutet:
Ermöglicht einen Funktionstest des REHOILER.
Bei jedem Tacho- bzw. Reed-Impuls wird die gelbe LED auf
der Platine wechselweise ein- und ausgeschaltet.
Dieser Testmodus sollte aber nach Neustart beendet sein.

So, jetzt aber noch was wichtiges, bei Problemen immer Hardwareversion und installierte Softwareversion angeben.

Grüsse
turboschleicher

#5 RE: Sicherung durchgebrannt von Ensomhet 20.11.2013 22:54

Hallo turboschleicher,
auch, wenn ich es noch so sehr kontrolliert habe, vertue ich mich da dann wohl mit irgendwas, was die Polarität angeht. Nunja, es funktioniert ja nun, das ist die Hauptsache.

Ähm, ja, natürlich. Das hatte ich vergessen zu erwähnen. Hardware- und Softwareversion sind aktuell (die Hardware ist die gleiche, wie aus der Anleitung 7.83 und die Software-Version ist 8.01).
Ich kann die Werte also per USB auslesen und verändern. Die sind schon noch alle richtig.

Du hast mich glaube ich falsch verstanden. Ich hatte mich ja ziemlich vertan. Und nun habe ich das mit der dauerhaft leuchtenden grünen LED auch in der Anleitung entdeckt (unter "Automatischer Notbetrieb"). Was mich durcheinanderbrachte war ja eben, die sich nach x Sekunden (bei mir 8) einschaltende grüne LED. Ich hatte aus der Anleitung nicht herausgelesen, dass das durch die Reedkontakt-Kontrolle bedingt ist und durch die grüne LED signalisiert wird, dass der automatische Notbetrieb aus ist. Als ich die LEDs und den Taster gestern testete, war das im Stand, deswegen leuchtete die grüne LED eben einfach dauerhaft. Erst als ich vorhin eine Testfahrt gemacht habe, schien alles wieder Sinn zu ergeben und ich verstand, wann die grüne LED dauerleuchtet.
Ich hoffe, nun hast du mein Missverstehen verstanden.
Das hat sich ja nun durch die Testfahrt von alleine geklärt.
Die einzig offene Frage bleibt noch, was passiert, wenn man den Regen-/Offroad-Taster betätigt, nachdem die Reedkontakt-Kontrolle angesprochen hat. Also während die grüne LED leuchtet.
Dann geht die grüne LED beim ersten Betätigen aus, beim zweiten blinkt sie zwei mal (und geht dann wieder aus) und beim dritten Mal leuchtet sie wieder dauerhaft... Aber was bewirkt das? Dazu konnte ich leider nichts in der Anleitung finden. Vielleicht habe ich es auch bloß wieder übersehen...

#6 RE: Sicherung durchgebrannt von turboschleicher 21.11.2013 21:12

avatar

Hallo Evren,
schön das nix defekt gegangen ist und einfach die Sicherung einwenig knapp bemessen wahr. Das liegt vielleicht an der Serienstreuung der Pumpen. Dete hat ja eine 2,5A Sicherung empfohlen. Wenn vermehrt weitere User mit Durchgebrannter Sicherung sich melden, wäre dann eine Anpassung in der Anleitung kein Problem. Die Sicherung dienht in erster Linie als Schutz für's Motorrad; also zum Schutz vor Kabelbrand. Und wenn die Pumpe einen Kurzschluss hätte, da würde sogar eine 5A Sicherung reichen um den Schalttransistor zu schützen.
Ich habe den Quellcode der Aktuellen Software nicht da, kann dir also nicht wirklich sagen wie sich die LED verhält.
Kannst ja mal den Reedkontakt abhängen und schaun was angezeigt wird und hier berichten.

Grüsse
turboschleicher

#7 RE: Sicherung durchgebrannt von Ensomhet 22.11.2013 00:04

Hallo turboschleicher,
jap, ich bin auch begeistert davon, dass nun alles funktioniert. Ich muss nur noch für die Cockpit-LEDs und den Taster einen passenden Ort finden, ohne ins Tachogehäuse zu bohren.
Danke für deine Hilfe!

Was dann angezeigt wird, habe ich hier doch geschrieben:

Zitat von Ensomhet

[...] Dann geht die grüne LED beim ersten Betätigen aus, beim zweiten blinkt sie zwei mal (und geht dann wieder aus) und beim dritten Mal leuchtet sie wieder dauerhaft... [...]



Ich wollte wissen, was dann getan wird vom Rehoiler. Wird trotzdem der Regenmodus aktiviert und die Anzeige ist hier nur eine andere? Also dass eben statt der gelben die grüne LED leuchtet.
Oder ob das Betätigen hier etwas ganz anderes bewirkt.
Nunja, mal schauen, was Dete dazu sagt, sobald er mal hier reinschaut.

Achja, ist der Rehoiler Code eigentlich "Open Source"? Ich kann zwar kein BASCOM, aber den Code verstehen sollte ich trotzdem können, da ich andere Programmiersprachen beherrsche und vor Jahren auch mal Visual Basic gelernt hatte.

#8 RE: Sicherung durchgebrannt von Dete 22.11.2013 06:13

Moin, ich kann dier gerne den Quellcode zusenden.

Wie du schon festgestellt hast leuchtet die Grüne Cockpit LED dauerhaft, wenn kein Signal kommt. Da die LEDs Antiparallel geschaltet sind, kommt es aber zu einer Überschneidung wenn du nun den Regenmodus aktivierst.

Also Grüne und Gelb wollen gleichzeitig Leuchten, was natürlich nicht geht.

Da ist noch ein kleiner BUG in der Software, in der nächsten Version werde ich das dahin gehend abändern das die Gelbe leuchtet und die Reedkontaktüberwachung von neuen gestartet wird. Sollte dann wieder über den defenierten Zeitraum kein Impuls erfolgen, geht wieder ganz normal die Grüne LED an.

Manches ist ganz simpel wenn man es selbst Programmiert hat, aber woher sollt ihr das wissen .

Aber cool Thomas das ich jetzt beruflich Unterwegs sein kann und du hilfst hier.
Vielen vielen Dank .

Sorry [rolling_eyes]

#9 RE: Sicherung durchgebrannt von Ensomhet 22.11.2013 16:52

Hallo Dete,

ja, sehr gerne. Ich würde mir das gerne mal anschauen. Ist nochmal etwas aufklärender, als eine Anleitung, da man dann auch weiß, wie intern alles verarbeitet wird.

Achso, okay, dann ist das Rätsel ja nun gelöst mit einer ganz simplen Erklärung.
Ja, genau, ohne Erklärung oder Quellcode kann man da eben vieles reininterpretieren.

#10 RE: Sicherung durchgebrannt von Dete 24.11.2013 21:32

Moin ich habe das jetzt in der Software geändert, die Reedkontrolle wird beim aktivieren des Regenmodus wieder auf Null gesetzt. Damit gibt es keine Überschneidung mehr, danke für den Stups so ist erheblich besser.

Software 8.02

#11 RE: Sicherung durchgebrannt von turboschleicher 24.11.2013 22:05

avatar

Die 8.02 ist nun Online:D
Ich werde die Software via USB und Bluetooth installieren und berichten.

Grüsse
turboschleicher

#12 RE: Sicherung durchgebrannt von Dete 24.11.2013 22:29

Also via Bluetooth wird schwierig, per USB wie folgt vorgehen:

USB Adapter an den PC anstecken, Platine anschlie0en bis auf die -5V (Gnd).
Nun die Bootloader Software starten und den Upload beginnen.
Wenn das #123.. kommt schnell die -5V (Gnd) anstöpseln.
Wenn alles geklappt sollte der Upload auf den Prozessor beginnen

Das ist auch noch das aktuelle Problem beim Bluetooth Adapter, hier bezeiht der Adpter ja die Spannung über die Platine.Würdest du dieser dann die Spannung klauen, bricht im gleichen moment auch die Verbindung zusammen und es findet keine Übertragung statt.

Aber eine gedankliche Lösung per Software ist schon in Arbeit.

#13 RE: Sicherung durchgebrannt von Ensomhet 25.11.2013 03:48

Ui, das ging ja schnell. Super!
Das Updaten hat problemlos geklappt und die "neue Funktion" funktioniert auch einwandfrei.

Es ist aber glaube ich ein kleiner Fehler vorhanden. In der Konfigurator Software steht seit dem Update nun bei "Rehoiler IQ Version" der Wert 65535 und bei Prozessor "8.02". Ist zwar nichts schlimmes, aber ich wollt's nicht unerwähnt lassen.

#14 RE: Sicherung durchgebrannt von Dete 25.11.2013 06:59

Ich habe nee 8.02 hoch geschoben ohne den Ausgabe Bug [cool]

Allerdings habe ich festgestellt das es besser ist den Null zu trennen statt der +5V leitung. Anders herum kann sich die Software aufhängen und im schlechtesten Fall kommt man dann nur per ISP an den Prozessor heran.

#15 RE: Sicherung durchgebrannt von Dete 25.11.2013 15:01

So ich habe das jetzt noch mal überarbeitet, ein Software Update ab Version 8.03 ist wie folgt zu machen:

DIP 1 und 4 auf ON stellen, Platinentaster betätigen.
Mit der MCS Bootloader Software den File Upload starten.
Wenn das Handshake erfolgreich und der Upload beginnt, kann der Taster los gelassen werden.

Wichtig beim Update von 8.01 oder 8.02 auf 8.03 muss noch mit trennen der Spannung (Gnd) gearbeitet werden. Die neue Update Funktion ist erst ab der Version 8.03 aktiv. Der Vorteil vom neuen Updateverfahren ist das nicht mehr die Spannung getrennt werden muss und auch ein Update per Bluetooth Adapter möglich ist.

Xobor Einfach ein eigenes Forum erstellen | ©Xobor.de
Datenschutz